Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / gnome / gnome-vfs_2.6.0.bb
1 LICENSE = "GPL"
2 PR = "r3"
3
4 inherit gnome
5
6 DEPENDS = "libxml2 gconf libbonobo bzip2 gnome-mime-data orbit2 zlib samba"
7 RRECOMMENDS = "gnome-vfs-plugin-file shared-mime-info"
8
9 SRC_URI += "file://gconftool-lossage.patch;patch=1;pnum=1"
10
11 ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
12
13 FILES_${PN} += " ${libdir}/gnome-vfs-2.0/modules/*.so ${libdir}/bonobo/servers ${libdir}/bonobo/monikers/*.so ${libdir}/vfs"
14 FILES_${PN}-dev += " ${libdir}/gnome-vfs-2.0/modules/*.a ${libdir}/gnome-vfs-2.0/modules/*.la ${libdir}/gnome-vfs-2.0/include ${libdir}/bonobo/monikers/*.a ${libdir}/bonobo/monikers/*.la"
15 FILES_${PN}-doc += " ${datadir}/gtk-doc"
16
17 GNOME_VFS_HEADERS = " \
18 gnome-vfs-utils.h \
19 gnome-vfs-application-registry.h \
20 gnome-vfs-async-ops.h \
21 gnome-vfs-ops.h \
22 gnome-vfs-uri.h \
23 gnome-vfs-standard-callbacks.h \
24 gnome-vfs-module-callback.h \
25 gnome-vfs-context.h \
26 gnome-vfs-file-info.h \
27 gnome-vfs-directory.h \
28 gnome-vfs-mime-monitor.h \
29 gnome-vfs-mime-handlers.h \
30 gnome-vfs-result.h \
31 gnome-vfs-job-limit.h \
32 gnome-vfs-file-size.h \
33 gnome-vfs-mime-utils.h \
34 gnome-vfs-find-directory.h \
35 gnome-vfs-init.h \
36 gnome-vfs-handle.h \
37 gnome-vfs.h \
38 gnome-vfs-cancellation.h \
39 gnome-vfs-xfer.h \
40 gnome-vfs-monitor.h \
41 gnome-vfs-types.h \
42 gnome-vfs-volume-monitor.h \
43 gnome-vfs-drive.h \
44 gnome-vfs-volume.h \
45 gnome-vfs-enum-types.h"
46
47 GNOME_VFS_MODULE_HEADERS = " \
48 gnome-vfs-mime-info.h \
49 gnome-vfs-transform.h \
50 gnome-vfs-ssl.h \
51 gnome-vfs-inet-connection.h \
52 gnome-vfs-socket.h \
53 gnome-vfs-parse-ls.h \
54 gnome-vfs-method.h \
55 gnome-vfs-cancellable-ops.h \
56 gnome-vfs-module.h \
57 gnome-vfs-module-shared.h \
58 gnome-vfs-module-callback-module-api.h \
59 gnome-vfs-mime.h \
60 gnome-vfs-socket-buffer.h"
61
62 do_compile() {
63         oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}"
64 }
65
66 do_stage() {
67         oe_libinstall -so -C libgnomevfs libgnomevfs-2 ${STAGING_LIBDIR}
68         install -d ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs
69         for i in ${GNOME_VFS_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-2.0/libgnomevfs/; done
70         install -d ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs
71         for i in ${GNOME_VFS_MODULE_HEADERS}; do install -m 0644 libgnomevfs/$i ${STAGING_INCDIR}/gnome-vfs-module-2.0/libgnomevfs/; done
72 }
73
74 do_install() {
75         oe_runmake ORBIT_IDL="${ORBIT_IDL_SRC}" DESTDIR="${D}" install
76 }