openmoko-session2: add RDEPENDS openmoko-panel-memory and oe-stylize
[vuplus_openembedded] / packages / glibc / glibc_cvs.bb
1 require glibc.inc
2
3 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs-2.3.5"
4 PR = "r6"
5 PV = "2.3.5+cvs${SRCDATE}"
6
7 GLIBC_ADDONS ?= "ports,linuxthreads"
8
9 DEFAULT_PREFERENCE = "-1"
10
11 #
12 # For now, we will skip building of a gcc package if it is a uclibc one
13 # and our build is not a uclibc one, and we skip a glibc one if our build
14 # is a uclibc build.
15 #
16 # See the note in gcc/gcc_3.4.0.oe
17 #
18
19 python __anonymous () {
20     import bb, re
21     uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
22     if uc_os:
23         raise bb.parse.SkipPackage("incompatible with target %s" %
24                                    bb.data.getVar('TARGET_OS', d, 1))
25 }
26
27 RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
28
29 #          file://noinfo.patch;patch=1
30 #          file://ldconfig.patch;patch=1;pnum=0
31 #          file://arm-no-hwcap.patch;patch=1;pnum=0 \
32 #          file://arm-memcpy.patch;patch=1;pnum=0 \
33 #          file://arm-machine-gmon.patch;patch=1;pnum=0 \
34 #          \
35 #          file://arm-ioperm.patch;patch=1;pnum=0 \
36 #          file://ldd.patch;patch=1;pnum=0 \
37 SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc \
38            cvs://anoncvs@sources.redhat.com/cvs/glibc;module=ports \
39            file://arm-audit.patch;patch=1 \
40            file://arm-audit2.patch;patch=1 \
41            file://arm-memcpy.patch;patch=1 \
42            file://arm-longlong.patch;patch=1;pnum=0 \
43            file://fhs-linux-paths.patch;patch=1 \
44            file://dl-cache-libcmp.patch;patch=1 \
45            file://ldsocache-varrun.patch;patch=1 \
46            file://etc/ld.so.conf \
47            file://generate-supported.mk"
48
49 # seems to fail on tls platforms
50 SRC_URI_append_arm = " file://dyn-ldconfig-20041128.patch;patch=1"
51
52 S = "${WORKDIR}/libc"
53 B = "${WORKDIR}/build-${TARGET_SYS}"
54
55 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
56                 --without-cvs --disable-profile --disable-debug --without-gd \
57                 --enable-clocale=gnu \
58                 --enable-add-ons=${GLIBC_ADDONS} \
59                 --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
60                 --without-selinux \
61                 ${GLIBC_EXTRA_OECONF}"
62
63 EXTRA_OECONF += "${@get_glibc_fpu_setting(bb, d)}"
64
65 do_munge() {
66         # Integrate ports into tree
67         mv ${WORKDIR}/ports ${S}
68 }
69
70 addtask munge before do_patch after do_unpack
71
72 do_configure () {
73 # override this function to avoid the autoconf/automake/aclocal/autoheader
74 # calls for now
75 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
76 # version check and doesn't really help with anything
77         if [ -z "`which rpcgen`" ]; then
78                 echo "rpcgen not found.  Install glibc-devel."
79                 exit 1
80         fi
81         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
82         CPPFLAGS="" oe_runconf
83 }
84
85 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
86           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
87           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
88
89 do_compile () {
90         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
91         unset LDFLAGS
92         base_do_compile
93         (
94                 cd ${S}/sunrpc/rpcsvc
95                 for r in ${rpcsvc}; do
96                         h=`echo $r|sed -e's,\.x$,.h,'`
97                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
98                 done
99         )
100 }
101
102 require glibc-stage.inc
103
104 require glibc-package.bbclass