openmoko-session2: add RDEPENDS openmoko-panel-memory and oe-stylize
[vuplus_openembedded] / packages / glibc / glibc_2.3.3+cvs20050420.bb
1 require glibc.inc
2
3 DEFAULT_PREFERENCE_i586 = "0"
4
5 DEFAULT_PREFERENCE_sh3 = "-99"
6
7 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs"
8 PR = "r6"
9
10 GLIBC_ADDONS ?= "linuxthreads"
11
12 DEFAULT_PREFERENCE = "-1"
13
14 #          file://noinfo.patch;patch=1
15 #          file://ldconfig.patch;patch=1;pnum=0
16 SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc;date=${@bb.data.getVar('PV', d, 1)[9:]} \
17            file://arm-ioperm.patch;patch=1;pnum=0 \
18            file://fhs-linux-paths.patch;patch=1 \
19            file://arm-no-hwcap.patch;patch=1;pnum=0 \
20            file://arm-memcpy.patch;patch=1;pnum=0 \
21            file://arm-longlong.patch;patch=1;pnum=0 \
22            file://arm-machine-gmon.patch;patch=1;pnum=0 \
23            file://trampoline.patch;patch=1;pnum=0 \
24            file://eabi-patch-1;patch=1 \
25            file://eabi-patch-2;patch=1 \
26            file://eabi-patch-3;patch=1 \
27            file://5090_all_stubs-rule-fix.patch;patch=1 \
28            file://etc/ld.so.conf \
29            file://generate-supported.mk"
30
31 # seems to fail on tls platforms
32 SRC_URI_append_arm = " file://dyn-ldconfig-20041128.patch;patch=1"
33
34 SRC_URI_append_openmn = " file://ldsocache-varrun.patch;patch=1"
35
36 S = "${WORKDIR}/libc"
37 B = "${WORKDIR}/build-${TARGET_SYS}"
38
39 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
40                 --without-cvs --disable-profile --disable-debug --without-gd \
41                 --enable-clocale=gnu \
42                 --enable-add-ons=${GLIBC_ADDONS} \
43                 --with-headers=${CROSS_DIR}/${TARGET_SYS}/include \
44                 --without-selinux \
45                 ${GLIBC_EXTRA_OECONF}"
46
47 do_configure () {
48 # override this function to avoid the autoconf/automake/aclocal/autoheader
49 # calls for now
50 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
51 # version check and doesn't really help with anything
52         if [ -z "`which rpcgen`" ]; then
53                 echo "rpcgen not found.  Install glibc-devel."
54                 exit 1
55         fi
56         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
57         CPPFLAGS="" oe_runconf
58 }
59
60 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
61           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
62           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
63
64 do_compile () {
65         # this really is arm specific
66         touch ${S}/sysdeps/arm/framestate.c
67         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
68         unset LDFLAGS
69         base_do_compile
70         (
71                 cd ${S}/sunrpc/rpcsvc
72                 for r in ${rpcsvc}; do
73                         h=`echo $r|sed -e's,\.x$,.h,'`
74                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
75                 done
76         )
77 }
78
79 require glibc-stage.inc
80
81 require glibc-package.bbclass