merge of '178eac00dc5aa8338d42e8e203633bec7817bbf6'
[vuplus_openembedded] / packages / glibc / glibc_2.3.3+cvs20050221.bb
1 require glibc.inc
2
3 DEFAULT_PREFERENCE_sh3 = "-99"
4
5 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs"
6 PR = "r8"
7
8 GLIBC_ADDONS ?= "linuxthreads"
9
10 DEFAULT_PREFERENCE = "-1"
11 DEFAULT_PREFERENCE_i686 = "0"
12 DEFAULT_PREFERENCE_sh3 = "0"
13 DEFAULT_PREFERENCE_sh4 = "0"
14
15 #          file://noinfo.patch;patch=1
16 #          file://ldconfig.patch;patch=1;pnum=0
17 SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc;date=${@bb.data.getVar('PV', d, 1)[9:]} \
18            file://arm-ioperm.patch;patch=1;pnum=0 \
19            file://fhs-linux-paths.patch;patch=1 \
20            file://arm-no-hwcap.patch;patch=1;pnum=0 \
21            file://arm-memcpy.patch;patch=1;pnum=0 \
22            file://arm-longlong.patch;patch=1;pnum=0 \
23            file://arm-machine-gmon.patch;patch=1;pnum=0 \
24            file://trampoline.patch;patch=1;pnum=0 \
25            file://dl-cache-libcmp.patch;patch=1 \
26            \
27            file://etc/ld.so.conf \
28            file://generate-supported.mk"
29
30 # seems to fail on tls platforms
31 SRC_URI_append_arm = " file://dyn-ldconfig-20041128.patch;patch=1"
32
33 SRC_URI_append_openmn = " file://ldsocache-varrun.patch;patch=1"
34
35 S = "${WORKDIR}/libc"
36 B = "${WORKDIR}/build-${TARGET_SYS}"
37
38 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
39                 --without-cvs --disable-profile --disable-debug --without-gd \
40                 --enable-clocale=gnu \
41                 --enable-add-ons=${GLIBC_ADDONS} \
42                 --with-headers=${STAGING_INCDIR} \
43                 --without-selinux \
44                 ${GLIBC_EXTRA_OECONF}"
45
46 do_configure () {
47 # override this function to avoid the autoconf/automake/aclocal/autoheader
48 # calls for now
49 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
50 # version check and doesn't really help with anything
51         if [ -z "`which rpcgen`" ]; then
52                 echo "rpcgen not found.  Install glibc-devel."
53                 exit 1
54         fi
55         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
56         CPPFLAGS="" oe_runconf
57 }
58
59 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
60           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
61           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
62
63 do_compile () {
64         # this really is arm specific
65         touch ${S}/sysdeps/arm/framestate.c
66         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
67         unset LDFLAGS
68         base_do_compile
69         (
70                 cd ${S}/sunrpc/rpcsvc
71                 for r in ${rpcsvc}; do
72                         h=`echo $r|sed -e's,\.x$,.h,'`
73                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
74                 done
75         )
76 }
77
78 require glibc-stage.inc
79
80 require glibc-package.bbclass