merge of '178eac00dc5aa8338d42e8e203633bec7817bbf6'
[vuplus_openembedded] / packages / glibc / glibc_2.3.2+cvs20040726.bb
1 require glibc.inc
2
3 DEFAULT_PREFERENCE_sh3 = "-99"
4
5 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs"
6 PR = "r23"
7
8 GLIBC_ADDONS ?= "linuxthreads"
9
10 #          file://noinfo.patch;patch=1
11 #          file://ldconfig.patch;patch=1;pnum=0
12 SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc;date=${@bb.data.getVar('PV', d, 1)[9:]} \
13            file://arm-ioperm.patch;patch=1;pnum=0 \
14            file://makeconfig.patch;patch=1;pnum=0 \
15            file://ldd.patch;patch=1;pnum=0 \
16            file://fhs-linux-paths.patch;patch=1 \
17            file://arm-no-hwcap.patch;patch=1;pnum=0 \
18            file://arm-memcpy.patch;patch=1;pnum=0 \
19            file://arm-longlong.patch;patch=1;pnum=0 \
20            file://arm-machine-gmon.patch;patch=1;pnum=0 \
21            file://glibc-fp-byteorder.patch;patch=1 \
22            \
23            file://etc/ld.so.conf \
24            file://generate-supported.mk"
25
26 # seems to fail on tls platforms
27 SRC_URI_append_arm = " file://dyn-ldconfig.patch;patch=1;pnum=0"
28
29 SRC_URI_append_openmn = " file://ldsocache-varrun.patch;patch=1"
30
31 S = "${WORKDIR}/libc"
32 B = "${WORKDIR}/build-${TARGET_SYS}"
33
34 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
35                 --without-cvs --disable-profile --disable-debug --without-gd \
36                 --enable-clocale=gnu \
37                 --enable-add-ons=${GLIBC_ADDONS} \
38                 --with-headers=${STAGING_INCDIR} \
39                 ${GLIBC_EXTRA_OECONF}"
40
41 do_configure () {
42 # override this function to avoid the autoconf/automake/aclocal/autoheader
43 # calls for now
44 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
45 # version check and doesn't really help with anything
46         if [ -z "`which rpcgen`" ]; then
47                 echo "rpcgen not found.  Install glibc-devel."
48                 exit 1
49         fi
50         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
51         CPPFLAGS="" oe_runconf
52 }
53
54 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
55           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
56           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
57
58 do_compile () {
59         # this really is arm specific
60         touch ${S}/sysdeps/arm/framestate.c
61         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
62         unset LDFLAGS
63         base_do_compile
64         (
65                 cd ${S}/sunrpc/rpcsvc
66                 for r in ${rpcsvc}; do
67                         h=`echo $r|sed -e's,\.x$,.h,'`
68                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
69                 done
70         )
71 }
72
73 require glibc-stage.inc
74
75 require glibc-package.bbclass