merge of '7393275c6ccce67cadeb49d4afb3459e56edf8a9'
[vuplus_openembedded] / packages / gettext / gettext_0.14.1.bb
1 DESCRIPTION = "The GNU internationalization library."
2 HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
3 SECTION = "libs"
4 LICENSE = "GPL"
5 PR = "r8"
6 PROVIDES = "virtual/libintl"
7
8 SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
9            file://gettext-vpath.patch;patch=1;pnum=1 \
10            file://fixchicken.patch;patch=1;pnum=1 \
11            file://getline.m4.patch;patch=1 \
12            file://disable_java.patch;patch=1"
13
14 SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch;patch=1"
15 SRC_URI_append_linux-uclibcgnueabi = " file://gettext-error_print_progname.patch;patch=1"
16
17 PARALLEL_MAKE = ""
18
19 inherit autotools
20
21 EXTRA_OECONF += "--without-lisp --disable-csharp"
22 acpaths = '-I ${S}/autoconf-lib-link/m4/ \
23            -I ${S}/gettext-runtime/m4 \
24            -I ${S}/gettext-tools/m4'
25
26 do_configure_prepend() {
27         rm -f ${S}/config/m4/libtool.m4
28         install -m 0644 ${STAGING_DATADIR}/aclocal/libtool.m4 ${S}/config/m4/
29 }
30
31 # these lack the .x behind the .so, but shouldn't be in the -dev package
32 # Otherwise you get the following results:
33 # 7.4M    glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
34 # 25M     uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
35 # because gettext depends on gettext-dev, which pulls in more -dev packages:
36 # 15228   KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
37 # 1300    KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
38 # 140     KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
39 # 4       KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
40
41 PACKAGES =+ "libgettextlib libgettextsrc"
42 FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
43 FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
44
45 do_stage () {
46         autotools_stage_all
47 }