conf/distro/jlime-donkey.conf : Added parted & Dialog to distro_rdepends
[vuplus_openembedded] / packages / gcc / gcc_4.1.1.bb
1 PR = "r7"
2 DESCRIPTION = "The GNU cc and gcc C compilers."
3 HOMEPAGE = "http://www.gnu.org/software/gcc/"
4 SECTION = "devel"
5 LICENSE = "GPL"
6
7 inherit autotools gettext
8
9 require gcc-package.inc
10
11 SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
12         file://100-uclibc-conf.patch;patch=1 \
13         file://110-arm-eabi.patch;patch=1 \
14         file://200-uclibc-locale.patch;patch=1 \
15         file://300-libstdc++-pic.patch;patch=1 \
16         file://301-missing-execinfo_h.patch;patch=1 \
17         file://302-c99-snprintf.patch;patch=1 \
18         file://303-c99-complex-ugly-hack.patch;patch=1 \
19         file://304-index_macro.patch;patch=1 \
20         file://602-sdk-libstdc++-includes.patch;patch=1 \
21         file://740-sh-pr24836.patch;patch=1 \
22         file://800-arm-bigendian.patch;patch=1 \
23         file://arm-nolibfloat.patch;patch=1 \
24         file://arm-softfloat.patch;patch=1 \
25         file://gcc41-configure.in.patch;patch=1 \
26         file://arm-thumb.patch;patch=1 \
27         file://arm-thumb-cache.patch;patch=1 \
28         file://ldflags.patch;patch=1 \
29         file://cse.patch;patch=1 \
30         file://zecke-xgcc-cpp.patch;patch=1 \
31         file://unbreak-armv4t.patch;patch=1 \
32         "
33
34 SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
35
36 #Set the fortran bits
37 # 'fortran' or '', not 'f77' like gcc3 had 
38 FORTRAN = "" 
39 HAS_GFORTRAN = "no"
40 HAS_G2C = "no"
41
42 #Set the java bits
43 JAVA_arm = ""  
44
45 LANGUAGES = "c,c++${FORTRAN}${JAVA}"
46 require gcc3-build.inc
47
48
49 EXTRA_OECONF += " --disable-libssp "
50