Qtopia/X11: Install the right Qtopia XSession start script as well
[vuplus_openembedded] / packages / gcc / gcc_4.1.1.bb
1 DESCRIPTION = "The GNU cc and gcc C compilers."
2 HOMEPAGE = "http://www.gnu.org/software/gcc/"
3 SECTION = "devel"
4 LICENSE = "GPL"
5 PR = "r18"
6
7 inherit autotools gettext
8
9 require gcc-package.inc
10
11 SRC_URI = "http://ftp.gnu.org/pub/gnu/gcc/gcc-4.1.1/gcc-4.1.1.tar.bz2 \
12         file://100-uclibc-conf.patch;patch=1 \
13         file://110-arm-eabi.patch;patch=1 \
14         file://200-uclibc-locale.patch;patch=1 \
15         file://300-libstdc++-pic.patch;patch=1 \
16         file://301-missing-execinfo_h.patch;patch=1 \
17         file://302-c99-snprintf.patch;patch=1 \
18         file://303-c99-complex-ugly-hack.patch;patch=1 \
19         file://304-index_macro.patch;patch=1 \
20         file://602-sdk-libstdc++-includes.patch;patch=1 \
21         file://740-sh-pr24836.patch;patch=1 \
22         file://800-arm-bigendian.patch;patch=1 \
23         file://801-arm-bigendian-eabi.patch;patch=1 \
24         file://arm-nolibfloat.patch;patch=1 \
25         file://arm-softfloat.patch;patch=1 \
26         file://gcc41-configure.in.patch;patch=1 \
27         file://arm-thumb.patch;patch=1 \
28         file://arm-thumb-cache.patch;patch=1 \
29         file://ldflags.patch;patch=1 \
30         file://cse.patch;patch=1 \
31         file://zecke-xgcc-cpp.patch;patch=1 \
32         file://unbreak-armv4t.patch;patch=1 \
33         file://fix-ICE-in-arm_unwind_emit_set.diff;patch=1 \
34         file://gcc-4.1.1-pr13685-1.patch;patch=1 \
35         file://gcc-ignore-cache.patch;patch=1 \
36         file://gcc-4.1.1-e300cx.patch;patch=1 \
37         file://pr34130.patch;patch=1 \
38         "
39
40 SRC_URI_append_sh3  = " file://sh3-installfix-fixheaders.patch;patch=1 "
41
42 #This is a dirty hack to get gcc 4.1.1 to compile for glibc AND uclibc on ppc
43 #the patch that is need it to get gcc support soft-floats with glibc, makes gcc fail with uclibc
44 SRC_URI_append_linux = " file://ppc-gcc-41-20060515.patch;patch=1 \
45                          file://ppc-sfp-long-double-gcc411-7.patch;patch=1 "
46
47
48 #Set the fortran bits
49 # 'fortran' or '', not 'f77' like gcc3 had
50 FORTRAN = ""
51
52 #Set the java bits
53 JAVA_arm = ""
54 JAVA = ""
55
56 LANGUAGES = "c,c++${FORTRAN}${JAVA}"
57 require gcc3-build.inc
58
59
60 EXTRA_OECONF += " --disable-libssp "
61