Qtopia/X11: Install the right Qtopia XSession start script as well
[vuplus_openembedded] / packages / gcc / gcc_4.0.2.bb
1 DESCRIPTION = "The GNU cc and gcc C compilers."
2 HOMEPAGE = "http://www.gnu.org/software/gcc/"
3 SECTION = "devel"
4 LICENSE = "GPL"
5 DEPENDS = "mpfr gmp"
6 PR = "r7"
7
8 inherit autotools gettext
9
10 require gcc-package.inc
11
12 SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
13         file://arm-nolibfloat.patch;patch=1 \
14         file://arm-softfloat.patch;patch=1 \
15         file://ldflags.patch;patch=1 \
16         file://GCOV_PREFIX_STRIP-cross-profile_4.1.patch;patch=1 \
17         file://zecke-xgcc-cpp.patch;patch=1 "
18
19 # uclibc patches below
20 SRC_URI_append = " file://100-uclibc-conf.patch;patch=1   \
21                    file://200-uclibc-locale.patch;patch=1 \
22                    file://301-missing-execinfo_h.patch;patch=1 \
23                    file://302-c99-snprintf.patch;patch=1  \
24                    file://303-c99-complex-ugly-hack.patch;patch=1 \
25                    file://800-arm-bigendian.patch;patch=1 \
26                    file://zecke-host-cpp-ac-hack.patch;patch=1 \
27                    file://gcc-4.0.2-atmel.0.99.2.patch;patch=1 \
28                    "
29
30 SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
31
32
33 require gcc4-build.inc
34
35 EXTRA_OECONF += "--disable-libssp"
36
37 FORTRAN = ""