openmoko-session2: add RDEPENDS openmoko-panel-memory and oe-stylize
[vuplus_openembedded] / packages / gcc / gcc-cross_4.1.2.bb
1 require gcc_${PV}.bb
2 # path mangling, needed by the cross packaging
3 require gcc-paths-cross.inc
4 inherit cross
5 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
6 # NOTE: split PR.  If the main .bb changes something that affects its *build*
7 # remember to increment this one too.
8 PR = "r14"
9
10 DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
11 PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
12
13 # cross build
14 require gcc3-build-cross.inc
15 # cross packaging
16 require gcc-package-cross.inc
17
18 SRC_URI_append_fail-fast = " file://zecke-no-host-includes.patch;patch=1 "
19
20 EXTRA_OECONF_append_avr32= "  --disable-libmudflap "
21
22 EXTRA_OECONF += "--disable-libunwind-exceptions --with-mpfr=${STAGING_DIR_NATIVE}${layout_exec_prefix}"