iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / freesmartphone / python-ophoned_git.bb
1 DESCRIPTION = "The Open Phone Daemon (Python Implementation)"
2 HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenPhoneServer"
3 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
4 SECTION = "console/network"
5 DEPENDS = "python-cython-native python-pyrex-native"
6 LICENSE = "GPLv2"
7 PV = "0.0.0+gitr${SRCREV}"
8 PR = "r1"
9
10 inherit distutils update-rc.d
11
12 INITSCRIPT_NAME = "ophoned"
13 INITSCRIPT_PARAMS = "defaults 21"
14
15 SRC_URI = "${FREESMARTPHONE_GIT}/python-ophoned.git;protocol=git;branch=master \
16            file://ophoned"
17 S = "${WORKDIR}/git"
18
19 do_install_append() {
20         install -d ${D}${sysconfdir}/init.d/
21         install -m 0755 ${WORKDIR}/ophoned ${D}${sysconfdir}/init.d/
22 #       install -m 0644 ${WORKDIR}/ophoned.conf ${D}${sysconfdir}
23         install -d ${D}${sysconfdir}/dbus-1/system.d/
24         mv -f ${D}${datadir}/etc/dbus-1/system.d/ophoned.conf ${D}${sysconfdir}/dbus-1/system.d/
25 }
26
27 RDEPENDS_${PN} += "\
28   python-dbus \
29   python-pygobject \
30   python-pyrtc \
31   python-pyserial \
32   python-syslog \
33 "
34
35 FILES_${PN} += "${sysconfdir}"