iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / freesmartphone / python-oeventd_git.bb
1 DESCRIPTION = "The Open Event Daemon Prototype in Python"
2 HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/OpenEventDaemon"
3 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
4 SECTION = "console/network"
5 DEPENDS = "python-cython-native python-pyrex-native"
6 LICENSE = "GPLv2"
7 PV = "0.0.0+gitr${SRCREV}"
8 PR = "r1"
9
10 inherit distutils update-rc.d
11
12 INITSCRIPT_NAME = "oeventd"
13 INITSCRIPT_PARAMS = "defaults 21"
14
15 SRC_URI = "\
16   ${FREESMARTPHONE_GIT}/eventd.git;protocol=git;branch=master \
17   file://oeventd \
18 "
19 S = "${WORKDIR}/git"
20
21 do_install_append() {
22         install -d ${D}${sysconfdir}/init.d/
23         install -m 0755 ${WORKDIR}/oeventd ${D}${sysconfdir}/init.d/
24         install -d ${D}${sysconfdir}/dbus-1/system.d/
25         mv -f ${D}${datadir}/etc/dbus-1/system.d/oeventd.conf ${D}${sysconfdir}/dbus-1/system.d/
26 }
27
28 RDEPENDS_${PN} += "\
29   python-dbus \
30   python-pygobject \
31   python-syslog \
32 "
33
34 FILES_${PN} += "${sysconfdir}"