Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / freesmartphone / pyneod_git.bb
1 DESCRIPTION = "Zad - daemons"
2 HOMEPAGE = "http://neo1973-germany.de/wiki/Zad"
3 AUTHOR = "M. Dietrich"
4 SECTION = "console/network"
5 DEPENDS = "python"
6 LICENSE = "GPL"
7 PV = "0.0.0+gitr${SRCREV}"
8 PR = "r0"
9
10 inherit update-rc.d
11
12 INITSCRIPT_NAME = "pyneod"
13 INITSCRIPT_PARAMS = "defaults 40"
14
15 SRC_URI = "${FREESMARTPHONE_GIT}/pyneo.git;protocol=git;branch=master"
16 S = "${WORKDIR}/git/pyneod"
17
18 export D := "${D}"
19 export PREFIX = "${prefix}"
20
21 do_compile() {
22         :
23 }
24
25 do_install() {
26         python setup.py
27 }
28
29 RCONFLICTS = "gsmd"
30 RREPLACES = "gsmd"
31 RDEPENDS = "\
32   python-codecs \
33   python-compression \
34   python-crypt \
35   python-curses \
36   python-datetime \
37   python-dbus \
38   python-fcntl \
39   python-gdbm \
40   python-gst \
41   python-html \
42   python-io \
43   python-lang \
44   python-logging \
45   python-math \
46   python-mime \
47   python-netclient \
48   python-netserver \
49   python-pickle \
50   python-pprint \
51   python-pycrypto \
52   python-pygobject \
53   python-pyserial \
54   python-re \
55   python-readline \
56   python-shell \
57   python-simplejson \
58   python-sqlite3 \
59   python-stringold \
60   python-syslog \
61   python-threading \
62   python-xml \
63   python-zlib \
64 "
65
66 FILES_${PN} = "${datadir} ${sysconfdir} ${bindir}"
67 PACKAGE_ARCH = "${MACHINE_ARCH}"