merge
[vuplus_openembedded] / packages / freesmartphone / gsm0710muxd_svn.bb
1 DESCRIPTION = "gsm 07.10 muxer userspace daemon"
2 HOMEPAGE = "http://www.freesmartphone.org"
3 AUTHOR = "M. Dietrich"
4 SECTION = "console/network"
5 DEPENDS = "intltool-native dbus dbus-glib"
6 RCONFLICTS = "gsmd"
7 RREPLACES = "gsmd"
8 LICENSE = "GPL"
9 PV = "0.0+svnr${SRCREV}"
10 PR = "r4"
11
12 SRC_URI = "svn://projects.linuxtogo.org/svn/smartphones/trunk/software;module=gsm0710muxd"
13 S = "${WORKDIR}/gsm0710muxd"
14
15 inherit autotools
16
17 do_install_append() {
18         # temp hack
19         mv -f ${D}${datadir}/dbus-1/system-services/org.freesmartphone.GSM.MUX.service ${D}${datadir}/dbus-1/system-services/org.mobile.mux.service
20 }
21
22 pkg_postinst_${PN}() {
23         # can't do this offline
24         if [ "x$D" != "x" ]; then
25                 exit 1
26         fi
27         # reload dbus configuration files
28         for i in `pidof dbus-daemon`; do
29                 kill -SIGHUP $i
30         done
31 }
32
33 FILES_${PN} += "${datadir}"
34