Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / freesmartphone / fso-abyss_git.bb
1 DESCRIPTION = "Abyss is a GSM 07.10 muxer userspace daemon"
2 HOMEPAGE = "http://www.freesmartphone.org/mediawiki/index.php/Implementations/Abyss"
3 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de>"
4 SECTION = "console/network"
5 DEPENDS = "vala-native dbus dbus-glib libgsm0710"
6 LICENSE = "GPL"
7 PV = "0.3.1+gitr${SRCREV}"
8 PR = "r0"
9
10 SRC_URI = "\
11   ${FREESMARTPHONE_GIT}/fso-abyss.git;protocol=git;branch=master \
12   file://abyss.conf \
13 "
14 S = "${WORKDIR}/git"
15
16 inherit autotools
17
18 do_install_append() {
19         install -d ${D}${sysconfdir}
20         install -m 0644 ${WORKDIR}/abyss.conf ${D}${sysconfdir}/
21 }
22
23 PACKAGES =+ "${PN}-config"
24
25 FILES_${PN} += "${sysconfdir} ${datadir}"
26 RRECOMMENDS_${PN} = "${PN}-config"
27
28 FILES_${PN}-config = "\
29   ${sysconfdir}/abyss.conf \
30 "
31
32 CONFFILES_${PN}-config = "\
33   ${sysconfdir}/abyss.conf \
34 "
35
36 PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"