Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / freesmartphone / frameworkd_git.bb
1 DESCRIPTION = "The reference implementation of the freesmartphone.org framework APIs"
2 HOMEPAGE = "http://www.freesmartphone.org"
3 AUTHOR = "Michael 'Mickey' Lauer <mlauer@vanille-media.de> et. al."
4 SECTION = "console/network"
5 DEPENDS = "python-cython-native python-pyrex-native"
6 LICENSE = "GPL"
7 PV = "0.8.4.2+gitr${SRCREV}"
8 PR = "r0"
9
10 inherit distutils update-rc.d
11
12 INITSCRIPT_NAME = "frameworkd"
13 INITSCRIPT_PARAMS = "defaults 29"
14
15 SRC_URI = "${FREESMARTPHONE_GIT}/framework.git;protocol=git;branch=stabilization/milestone4 \
16            file://frameworkd \
17            file://frameworkd.conf"
18 S = "${WORKDIR}/git"
19
20 do_install_append() {
21         install -d ${D}${sysconfdir}/init.d/
22         install -m 0755 ${WORKDIR}/frameworkd ${D}${sysconfdir}/init.d/
23         install -m 0644 ${WORKDIR}/frameworkd.conf ${D}${sysconfdir}
24 }
25
26 RDEPENDS_${PN} += "\
27   python-ctypes \
28   python-dbus \
29   python-datetime \
30   python-difflib \
31   python-pprint \
32   python-pygobject \
33   python-pyrtc \
34   python-pyserial \
35   python-pyyaml \
36   python-shell \
37   python-subprocess \
38   python-syslog \
39   python-textutils \
40   \
41   ${PN}-config \
42 "
43
44 RRECOMMENDS_${PN} += "\
45   alsa-utils-amixer \
46   python-gst \
47   ppp \
48 "
49
50 # recommend MUXer on platforms that require one
51 RRECOMMENDS_${PN}_append_om-gta01 = "gsm0710muxd"
52 RRECOMMENDS_${PN}_append_om-gta02 = "gsm0710muxd"
53
54 PACKAGES =+ "${PN}-config"
55 PACKAGE_ARCH_${PN}-config = "${MACHINE_ARCH}"
56
57 FILES_${PN}-config = "\
58   ${sysconfdir}/frameworkd.conf \
59   ${sysconfdir}/freesmartphone \
60 "
61 CONFFILES_${PN}-config = "\
62   ${sysconfdir}/frameworkd.conf \
63   ${sysconfdir}/freesmartphone/opreferences/conf/phone/silent.yaml \
64   ${sysconfdir}/freesmartphone/opreferences/conf/phone/default.yaml \
65   ${sysconfdir}/freesmartphone/opreferences/conf/profiles/default.yaml \
66   ${sysconfdir}/freesmartphone/opreferences/conf/rules/silent.yaml \
67   ${sysconfdir}/freesmartphone/opreferences/conf/rules/default.yaml \
68   ${sysconfdir}/freesmartphone/oevents/rules.yaml \
69 "
70
71 PACKAGE_ARCH_${PN} = "${BASE_PACKAGE_ARCH}"
72 FILES_${PN} += "${sysconfdir}/dbus-1 ${sysconfdir}/freesmartphone ${sysconfdir}/init.d ${datadir}"
73 FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/framework/subsystems/*/.debug"