Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / fluxbox / fluxbox_svn.bb
1 # Copyright Matthias Hentges <devel@hentges.net> (c) 2006
2
3 DESCRIPTION = "The Fluxbox WindowManager"
4 HOMEPAGE = "http://fluxbox.sourceforge.net"
5 LICENSE = "MIT"
6
7 PV = "0.99+svn${SRCDATE}"
8 FILE_PR = "r1"
9 PE = "1" 
10
11 SRC_URI = "svn://svn.berlios.de/fluxbox;module=trunk \
12            file://apps.gpe.* \
13            file://style.gpe-default \
14            file://fluxbox-gpe-session \
15            file://fluxbox-gpe.session \
16            file://keys.* \
17            file://keylaunchrc.fluxbox \
18            file://gpe-logout.fluxbox"
19
20 S = "${WORKDIR}/trunk"
21
22 inherit autotools
23
24 EXTRA_OECONF = "--disable-xmb \
25                 "
26
27 do_install_append() {
28         install -d ${D}${bindir}
29         install -d ${D}${datadir}/fluxbox
30         install -d ${D}${datadir}/fluxbox/styles
31         install -d ${D}/etc
32
33         install -m 0644 ${WORKDIR}/apps.gpe.* ${D}${datadir}/fluxbox
34         install -m 0644 ${WORKDIR}/keys.* ${D}${datadir}/fluxbox
35         install -m 0755 ${WORKDIR}/fluxbox-gpe.session ${D}${datadir}/fluxbox/session
36         install -m 0644 ${WORKDIR}/style.gpe-default ${D}${datadir}/fluxbox/styles/gpe-default
37         install -m 0755 ${WORKDIR}/fluxbox-gpe-session ${D}${bindir}
38         install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}${bindir}
39         install -m 0644 ${WORKDIR}/keylaunchrc.fluxbox ${D}/etc
40 }
41
42 PACKAGES = "${PN}-dbg ${PN}-gpe ${PN}-styles ${PN}-doc ${PN}"
43
44 DESCRIPTION_${PN}-styles = "The default styles for fluxbox"
45 DESCRIPTION_${PN}-gpe = "The Fluxbox WindowManager for use with GPE"
46 RDEPENDS_${PN}-gpe = "${PN}"
47
48 FILES_${PN} = "${bindir} \
49                ${datadir}/fluxbox/init \
50                ${datadir}/fluxbox/keys \
51                ${datadir}/fluxbox/menu "
52
53 FILES_${PN}-gpe = "${datadir}/fluxbox/apps.gpe* \
54                    ${datadir}/fluxbox/keys.* \
55                    ${bindir}/gpe-logout.fluxbox \
56                    ${sysconfdir}keylaunchrc.fluxbox \
57                    ${datadir}/fluxbox/styles/gpe-default \
58                    ${datadir}/fluxbox/session \
59                    ${bindir}/fluxbox-gpe-session"
60
61 FILES_${PN}-styles = "${datadir}/fluxbox/styles"
62
63 FILES_${PN}-doc = "${datadir}/man"
64
65
66 pkg_postinst_${PN}-gpe() {
67        update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/fluxbox-gpe-session 15
68        update-alternatives --install ${bindir}/gpe-logout gpe-logout ${bindir}/gpe-logout.fluxbox  15
69        update-alternatives --install ${sysconfdir}keylaunchrc keylaunchrc ${sysconfdir}keylaunchrc.fluxbox 15
70 }
71
72 pkg_postrm_${PN}-gpe() {
73        update-alternatives --remove x-window-manager ${bindir}/fluxbox-gpe-session
74        update-alternatives --remove gpe-logout ${bindir}/gpe-logout.fluxbox
75        update-alternatives --remove keylaunchrc ${sysconfdir}keylaunchrc.fluxbox
76 }