Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / fluxbox / fluxbox_0.99+1.0rc.bb
1 # Copyright Matthias Hentges <devel@hentges.net> (c) 2006
2
3 DESCRIPTION = "The Fluxbox WindowManager"
4 HOMEPAGE = "http://fluxbox.sourceforge.net"
5 LICENSE = "MIT"
6
7 REALPV = "1.0rc"
8
9 PV = "0.99+${REALPV}"
10 FILE_PR = "r1"
11 PE = "1" 
12
13
14 SRC_URI = "${SOURCEFORGE_MIRROR}/fluxbox/fluxbox-${REALPV}.tar.gz \
15            file://gpe-init.patch;patch=1 \
16            file://apps.gpe.* \
17            file://style.gpe-default \
18            file://fluxbox-gpe-session \
19            file://fluxbox-gpe.session \
20            file://keys.* \
21            file://keylaunchrc.fluxbox \
22            file://gpe-logout.fluxbox"
23
24 S = "${WORKDIR}/fluxbox-${REALPV}"
25
26 inherit autotools
27
28 EXTRA_OECONF = "--disable-xmb \
29                 "
30
31 do_install_append() {
32         install -d ${D}${bindir}
33         install -d ${D}${datadir}/fluxbox
34         install -d ${D}${datadir}/fluxbox/styles
35         install -d ${D}/etc
36
37         install -m 0644 ${WORKDIR}/apps.gpe.* ${D}${datadir}/fluxbox
38         install -m 0644 ${WORKDIR}/keys.* ${D}${datadir}/fluxbox
39         install -m 0755 ${WORKDIR}/fluxbox-gpe.session ${D}${datadir}/fluxbox/session
40         install -m 0644 ${WORKDIR}/style.gpe-default ${D}${datadir}/fluxbox/styles/gpe-default
41         install -m 0755 ${WORKDIR}/fluxbox-gpe-session ${D}${bindir}
42         install -m 0755 ${WORKDIR}/gpe-logout.fluxbox ${D}${bindir}
43         install -m 0644 ${WORKDIR}/keylaunchrc.fluxbox ${D}/etc
44 }
45
46 PACKAGES = "${PN}-dbg ${PN}-gpe ${PN}-styles ${PN}-doc ${PN}"
47
48 DESCRIPTION_${PN}-styles = "The default styles for fluxbox"
49 DESCRIPTION_${PN}-gpe = "The Fluxbox WindowManager for use with GPE"
50 RDEPENDS_${PN}-gpe = "${PN}"
51
52 FILES_${PN} = "${bindir} \
53                ${datadir}/fluxbox/init \
54                ${datadir}/fluxbox/keys \
55                ${datadir}/fluxbox/menu "
56
57 FILES_${PN}-gpe = "${datadir}/fluxbox/apps.gpe* \
58                    ${datadir}/fluxbox/keys.* \
59                    ${bindir}/gpe-logout.fluxbox \
60                    ${sysconfdir}/keylaunchrc.fluxbox \
61                    ${datadir}/fluxbox/styles/gpe-default \
62                    ${datadir}/fluxbox/session \
63                    ${bindir}/fluxbox-gpe-session"
64
65 FILES_${PN}-styles = "${datadir}/fluxbox/styles"
66
67 FILES_${PN}-doc = "${datadir}/man"
68
69
70 pkg_postinst_${PN}-gpe() {
71        update-alternatives --install ${bindir}/x-window-manager x-window-manager ${bindir}/fluxbox-gpe-session 15
72        update-alternatives --install ${bindir}/gpe-logout gpe-logout ${bindir}/gpe-logout.fluxbox  15
73        update-alternatives --install ${sysconfdir}keylaunchrc keylaunchrc ${sysconfdir}keylaunchrc.fluxbox 15
74 }
75
76 pkg_postrm_${PN}-gpe() {
77        update-alternatives --remove x-window-manager ${bindir}/fluxbox-gpe-session
78        update-alternatives --remove gpe-logout ${bindir}/gpe-logout.fluxbox
79        update-alternatives --remove keylaunchrc ${sysconfdir}keylaunchrc.fluxbox
80 }