rootfs_ipk.bbclass: fix string comparison
[vuplus_openembedded] / packages / ffmpeg / ffmpeg_git.bb
1 require ffmpeg.inc
2
3 DEPENDS += "schroedinger libgsm"
4
5 PE = "1"
6 PV = "0.4.9+${PR}+gitr${SRCREV}" 
7 PR = "r34"
8
9 DEFAULT_PREFERENCE = "-1"
10 DEFAULT_PREFERENCE_armv5te = "1"
11 DEFAULT_PREFERENCE_armv6 = "1"
12 DEFAULT_PREFERENCE_armv7a = "1"
13 DEFAULT_PREFERENCE_avr32 = "1"
14
15 FFBRANCH_arm = "arm"
16 FFBRANCH ?= "master"
17
18 # When bumping SRCREV make sure you bump PR here and in dependant recipes (gst-ffmpeg, gnash, omxil, etc) to account for SOVERSION changes
19 SRCREV = "b06c88bbec744970e023a03abed314f10d6936da"
20 SRCREV_arm = "afb98868e19e63cbca6c9f0ed9e6cfa48d40277d"
21 SRC_URI = "git://git.mansr.com/ffmpeg.mru;protocol=git;branch=${FFBRANCH} \
22 "
23
24 S = "${WORKDIR}/git"
25 B = "${S}/build.${HOST_SYS}.${TARGET_SYS}"
26
27 FULL_OPTIMIZATION_armv7a = "-fexpensive-optimizations  -ftree-vectorize -fomit-frame-pointer -O4 -ffast-math"
28 BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
29
30 EXTRA_FFCONF_armv7a = "--cpu=cortex-a8"
31 EXTRA_FFCONF ?= ""
32
33 EXTRA_OECONF = " \
34         --enable-shared \
35         --enable-pthreads \
36         --disable-stripping \
37         --enable-gpl \
38         --enable-nonfree \
39         --enable-postproc \
40         \
41         --cross-prefix=${TARGET_PREFIX} \
42         --prefix=${prefix} \
43         \
44         --enable-x11grab \
45         --enable-libfaac \
46         --enable-libfaad \
47         --enable-libfaadbin \
48         --enable-libgsm \
49         --enable-libmp3lame \
50         --enable-libschroedinger \
51         --enable-swscale \
52         --arch=${TARGET_ARCH} \
53         --enable-cross-compile \
54         --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}" \
55         --extra-ldflags="${TARGET_LDFLAGS}" \
56         --enable-hardcoded-tables \
57         ${EXTRA_FFCONF} \
58 "
59
60 do_configure() {
61         sed -i -e s:'check_cflags -std=c99'::g ${S}/configure
62         cd ${S} ; git clone git://git.mplayerhq.hu/libswscale || true  
63         mkdir -p ${B}
64         cd ${B}
65         ${S}/configure ${EXTRA_OECONF}
66                 sed -i -e s:Os:O4:g ${B}/config.h
67 }
68