linux-dm8000: use $KERNELORG_MIRROR to match checksums.ini
[vuplus_openembedded] / packages / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native  \
5         gstreamer gst-plugins-good gst-plugins-bad gst-plugins-ugly \
6         libfribidi libxmlccwrap libdreamdvd tuxbox-tuxtxt-32bpp"
7 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
8         python-xml python-fcntl gst-plugin-decodebin python-stringold \
9         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
10         gst-plugin-typefindfunctions gst-plugin-ivorbis gst-plugin-audioconvert \
11         gst-plugin-wavparse python-netclient gst-plugin-mpegstream"
12
13 RDEPENDS_append_dm7020 = " gst-plugin-ossaudio"
14 RDEPENDS_append_dm7025 = " gst-plugin-alsa alsa-conf"
15 RDEPENDS_append_dm8000 = " gst-plugin-alsa alsa-conf gst-plugin-avi gst-plugin-matroska"
16 RDEPENDS_append_dm800 = " gst-plugin-alsa alsa-conf"
17
18 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
19 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
20 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
21 DESCRIPTION_append_enigma2-plugin-systemplugins-configurationbackup = "backs up your configuration and restores them optionally."
22 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
23 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
24 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
25 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
26 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
27 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
28 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
29
30 export LD="${CXX}"
31
32 PN = "enigma2"
33 PR = "r4"
34 SRCDATE = "20080926"
35
36 # if you want experimental, use:
37 REL_MAJOR="2"
38 REL_MINOR="5"
39 TAG = ""
40
41 PV = "${REL_MAJOR}.${REL_MINOR}cvs${SRCDATE}"
42
43 SRC_URI = "cvs://anonymous@dreamboxupdate.com/cvs;module=enigma2;method=pserver${TAG};date=${SRCDATE} \
44         file://tuxtxt_caching.patch;patch=1 \
45         file://enigma2.sh"
46
47 SRC_URI_append_dm7025 = " file://enigma2-disable-iframesearch.patch;patch=1;pnum=1"
48
49 S = "${WORKDIR}/enigma2"
50
51 FILES_${PN} += "${datadir}/fonts"
52
53 inherit autotools pkgconfig
54
55 bindir = "/usr/bin"
56 sbindir = "/usr/sbin"
57
58 EXTRA_OECONF = "--enable-maintainer-mode --with-target=native --with-libsdl=no"
59
60 do_install_append() {
61         install -m 0755 ${WORKDIR}/enigma2.sh ${D}/usr/bin/
62 }
63
64 python populate_packages_prepend () {
65         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
66
67         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
68 }
69
70 do_stage_append() {
71         install -d ${STAGING_INCDIR}/enigma2
72         install -m 0644 ${WORKDIR}/enigma2/include/*.h ${STAGING_INCDIR}/enigma2
73         for dir in actions base components driver dvb dvb/lowlevel dvb_ci gdi gui mmi nav python service; do
74                 install -d ${STAGING_INCDIR}/enigma2/lib/$dir;
75                 install -m 0644 ${WORKDIR}/enigma2/lib/$dir/*.h ${STAGING_INCDIR}/enigma2/lib/$dir;
76         done
77 }