Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / enigma / ipkgpl.bb
1 DEPENDS = "enigma"
2 RDEPENDS = "enigma ipkg"
3 DESCRIPTION = "Enigma Plugin IPKG"
4 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
5 LICENSE = "GPL"
6 PV = "0.2.1"
7 PR = "r1"
8 SRC_URI =  "http://sources.dreamboxupdate.com/download/opendreambox/enigma/ipkgpl-${PV}-r1.tar.bz2"
9
10 S = "${WORKDIR}/ipkgpl"
11
12 FILES_${PN} =  "/usr/lib/tuxbox/plugins/ipkgpl.so \
13                 /usr/lib/tuxbox/plugins/ipkgpl.cfg"
14
15 inherit autotools pkgconfig
16
17 EXTRA_OECONF = "--with-target=native "
18
19 do_install() {
20         install -d ${D}/usr/lib/tuxbox/plugins
21         install ${S}/.libs/ipkgpl.so ${D}/usr/lib/tuxbox/plugins
22         install -m 0644 ${S}/ipkgpl.cfg ${D}/usr/lib/tuxbox/plugins
23 }