Move the RRECOMMEND for libgcc from glibc to busybox.
[vuplus_openembedded] / packages / eglibc / eglibc_svn.bb
1 require eglibc.inc
2
3 # DEFAULT_PREFERENCE = "-1"
4 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/eglibc-svn"
5 PV = "2.8+svnr${SRCREV}"
6 PR = "r9"
7 SRC_URI = "svn://svn.eglibc.org;module=trunk \
8            file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
9            file://etc/ld.so.conf \
10            file://generate-supported.mk"
11 S = "${WORKDIR}/trunk/libc"
12 B = "${WORKDIR}/build-${TARGET_SYS}"
13
14 PACKAGES_DYNAMIC = "libc6*"
15 RPROVIDES_${PN}-dev = "libc6-dev"
16 PROVIDES_${PN}-dbg = "glibc-dbg"
17
18 # the -isystem in bitbake.conf screws up glibc do_stage
19 BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
20 TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
21
22 GLIBC_ADDONS ?= "ports,nptl,libidn"
23
24 GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN"
25
26 #
27 # For now, we will skip building of a gcc package if it is a uclibc one
28 # and our build is not a uclibc one, and we skip a glibc one if our build
29 # is a uclibc build.
30 #
31 # See the note in gcc/gcc_3.4.0.oe
32 #
33
34 python __anonymous () {
35     import bb, re
36     uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
37     if uc_os:
38         raise bb.parse.SkipPackage("incompatible with target %s" %
39                                    bb.data.getVar('TARGET_OS', d, 1))
40 }
41
42            
43 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
44                 --without-cvs --disable-profile --disable-debug --without-gd \
45                 --enable-clocale=gnu \
46                 --enable-add-ons=${GLIBC_ADDONS} \
47                 --with-headers=${STAGING_INCDIR} \
48                 --without-selinux \
49                 ${GLIBC_EXTRA_OECONF}"
50
51 EXTRA_OECONF += "${@get_eglibc_fpu_setting(bb, d)}"
52
53 do_unpack_append() {
54         bb.build.exec_func('do_move_ports', d)
55 }
56
57 do_move_ports() {
58         if test -d ${WORKDIR}/trunk/ports ; then
59             rm -rf ${S}/ports
60             mv ${WORKDIR}/trunk/ports ${S}/
61         fi    
62 }
63
64 do_configure () {
65 # override this function to avoid the autoconf/automake/aclocal/autoheader
66 # calls for now
67 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
68 # version check and doesn't really help with anything
69         if [ -z "`which rpcgen`" ]; then
70                 echo "rpcgen not found.  Install glibc-devel."
71                 exit 1
72         fi
73         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
74         find ${S} -name "configure" | xargs touch
75         CPPFLAGS="" oe_runconf
76 }
77
78 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
79           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
80           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
81
82 do_compile () {
83         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
84         unset LDFLAGS
85         base_do_compile
86         (
87                 cd ${S}/sunrpc/rpcsvc
88                 for r in ${rpcsvc}; do
89                         h=`echo $r|sed -e's,\.x$,.h,'`
90                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
91                 done
92         )
93 }
94
95 require eglibc-stage.inc
96
97 require eglibc-package.bbclass