Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / eglibc / eglibc_2.9.bb
1 require eglibc.inc
2
3 DEPENDS += "gperf-native"
4 DEFAULT_PREFERENCE = "1"
5 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/eglibc-svn"
6 PV = "2.9"
7 PR = "r4"
8 SVN_REV="7430"
9 EGLIBC_BRANCH="eglibc-2_9"
10 SRC_URI = "svn://svn.eglibc.org/branches;module=eglibc-2_9;rev=${SVN_REV};proto=svn \
11            file://eglibc-svn-arm-lowlevellock-include-tls.patch;patch=1 \
12            file://etc/ld.so.conf \
13            file://generate-supported.mk"
14 S = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
15 B = "${WORKDIR}/build-${TARGET_SYS}"
16
17 PACKAGES_DYNAMIC = "libc6*"
18 RPROVIDES_${PN}-dev = "libc6-dev virtual-libc-dev"
19 PROVIDES_${PN}-dbg = "glibc-dbg"
20
21 # the -isystem in bitbake.conf screws up glibc do_stage
22 BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
23 TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${layout_includedir}"
24
25 GLIBC_ADDONS ?= "ports,nptl,libidn"
26
27 GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN"
28
29 #
30 # For now, we will skip building of a gcc package if it is a uclibc one
31 # and our build is not a uclibc one, and we skip a glibc one if our build
32 # is a uclibc build.
33 #
34 # See the note in gcc/gcc_3.4.0.oe
35 #
36
37 python __anonymous () {
38     import bb, re
39     uc_os = (re.match('.*uclibc$', bb.data.getVar('TARGET_OS', d, 1)) != None)
40     if uc_os:
41         raise bb.parse.SkipPackage("incompatible with target %s" %
42                                    bb.data.getVar('TARGET_OS', d, 1))
43 }
44
45 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
46                 --without-cvs --disable-profile --disable-debug --without-gd \
47                 --enable-clocale=gnu \
48                 --enable-add-ons=${GLIBC_ADDONS},ports \
49                 --with-headers=${STAGING_INCDIR} \
50                 --without-selinux \
51                 ${GLIBC_EXTRA_OECONF}"
52
53 EXTRA_OECONF += "${@get_eglibc_fpu_setting(bb, d)}"
54
55 do_unpack_append() {
56         bb.build.exec_func('do_move_ports', d)
57 }
58
59 do_move_ports() {
60         if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
61             rm -rf ${S}/ports
62             mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${S}/
63         fi
64 }
65
66 do_configure () {
67 # override this function to avoid the autoconf/automake/aclocal/autoheader
68 # calls for now
69 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
70 # version check and doesn't really help with anything
71         if [ -z "`which rpcgen`" ]; then
72                 echo "rpcgen not found.  Install glibc-devel."
73                 exit 1
74         fi
75         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
76         find ${S} -name "configure" | xargs touch
77         CPPFLAGS="" oe_runconf
78 }
79
80 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
81           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
82           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
83
84 do_compile () {
85         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
86         unset LDFLAGS
87         base_do_compile
88         (
89                 cd ${S}/sunrpc/rpcsvc
90                 for r in ${rpcsvc}; do
91                         h=`echo $r|sed -e's,\.x$,.h,'`
92                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
93                 done
94         )
95 }
96
97 require eglibc-stage.inc
98
99 require eglibc-package.bbclass