efl, e17: update to newest versions, split e and efl bbclasses and use e for e17...
[vuplus_openembedded] / packages / efl / ewl_0.0.4.006.bb
1 DESCRIPTION = "The Enlightened Widget Library, \
2 a simple-to-use general purpose widget library based on the enlightenment foundation libraries."
3 # as of recent CVS HEAD, ewl no longer needs etox and no longer needs edb
4 DEPENDS = "edb virtual/evas virtual/ecore edje emotion"
5 RDEPENDS += "libewl-themes"
6 LICENSE = "MIT"
7 PR = "r1"
8
9 inherit efl
10
11 SRC_URI += "file://ewl-configure.patch;patch=1 \
12             file://fix-ecore.patch;patch=1 \
13             file://ecore-flags.patch;patch=1 \
14             file://no-examples.patch;patch=1 \
15             file://minmax.patch;patch=1"
16
17 do_stage_append() {
18         for i in src/lib/ewl_*.h
19         do
20                 install -m 0644 $i ${STAGING_INCDIR}
21         done
22 }
23