efl, e17: update to newest versions, split e and efl bbclasses and use e for e17...
[vuplus_openembedded] / packages / efl / esmart-x11_20060128.bb
1 include esmart.inc
2 PR = "r2"
3
4 SRC_URI = "${E_CVS};module=e17/libs/esmart;date=${PV}"
5 SRC_URI += "file://ecore-fix.patch;patch=1 \
6             file://include-stdio.patch;patch=1 \
7             file://compile-fix.patch;patch=1"
8 S = "${WORKDIR}/esmart"
9
10 myheaders = "esmart_container/Esmart_Container.h \
11              esmart_draggies/Esmart_Draggies.h \
12              esmart_file_dialog/Esmart_File_Dialog.h \
13              esmart_text_entry/Esmart_Text_Entry.h \
14              esmart_textarea/Esmart_Textarea.h \
15              esmart_thumb/Esmart_Thumb.h \
16              esmart_trans_x11/Esmart_Trans_X11.h"
17
18 mylibraries = "esmart_container \
19                esmart_draggies \
20                esmart_file_dialog \
21                esmart_text_entry \
22                esmart_textarea \
23                esmart_thumb \
24                esmart_trans_x11"
25
26 do_compile_prepend() {
27         find ${S} -type f -name "*.[ch]" | xargs sed -i 's:NULL:0:g'
28 }