gnumeric: disable PARALLEL_MAKE close bug# 3500
[vuplus_openembedded] / packages / ecj / ecj-bootstrap-native_3.3.bb
1 # ECJ as a bootstrap compiler is a drop-in replacement for Sun's javac. It offers no more
2 # and no less features.
3 #
4 # Since the VM running the compiler has no effect on the produced bytecode this recipe
5 # uses the jar created by ecj-initial and creates a start script that runs it with a different
6 # VM.
7
8 DESCRIPTION = "JDT Core Batch Compiler - Bootstrap variant"
9 HOMEPAGE = "http://www.eclipse.org/"
10 SECTION = "devel"
11 PRIORITY = "optional"
12 LICENSE = "EPL"
13
14 DEPENDS = "ecj-initial virtual/java-native"
15
16 PROVIDES = "virtual/javac-native"
17
18 SRC_URI = "file://ecj.in"
19
20 S = "${WORKDIR}"
21
22 JAR = "ecj-bootstrap-${PV}.jar"
23
24 inherit native
25
26 do_compile() {
27   # Create the start script
28   echo "#!/bin/sh" > ecj-bootstrap
29   echo "ECJ_JAR=${STAGING_DATADIR}/java/${JAR}" >> ecj-bootstrap
30   echo "RUNTIME=java" >> ecj-bootstrap
31   cat ecj.in >> ecj-bootstrap
32 }
33
34 do_stage() {
35   install -d ${STAGING_BINDIR}
36   install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}
37   install -m 755 ${S}/ecj-bootstrap ${STAGING_BINDIR}/javac
38 }