merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / e17 / entrance_0.9.0.007.bb
1 DESCRIPTION = "Entrance is the Enlightenment login manager"
2 LICENSE = "MIT"
3 # can also use pam and crypt
4 DEPENDS = "edb edb-native evas-x11 ecore-x11 edje esmart-x11 bash keylaunch xserver-common login-manager"
5 RDEPENDS += "bash keylaunch xserver-common glibc-gconv-iso8859-1 login-manager entrance-themes"
6 HOMEPAGE = "http://www.enlightenment.org"
7 PR = "r13"
8
9 inherit e
10
11 SRC_URI = "${E_URI}/entrance-${PV}.tar.gz \
12            file://config-db.patch;patch=1 \
13            file://allow-missing-xsession.patch;patch=1 \
14            file://run-Xinit.patch;patch=1 \
15            file://set-display-env.patch;patch=1 \
16            file://fix-auth-mode.patch;patch=1 \
17            file://use-bash.patch;patch=1 \
18            file://disable-autodetect.patch;patch=1 \
19            file://Sessions"
20
21 S = "${WORKDIR}/entrance-${PV}"
22
23 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
24                 --with-xsession=/etc/X11/Xsession \
25                 --with-auth-mode=0"
26
27 FILES_${PN} += "${bindir} ${sbindir} /etc ${datadir}"
28
29 do_install_append() {
30         install -d ${D}/etc/X11/Xsession.d
31         install -d ${D}/etc/X11/Sessions
32         
33         install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
34
35         install -d ${D}/etc/X11/login-managers/
36         mv ${D}/etc/init.d/entrance ${D}/etc/X11/login-managers/entrance        
37 }