merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / e17 / e-wm_0.16.999.036.bb
1 DESCRIPTION = "E17 - the Enlightenment Window Mananger"
2 DEPENDS = "evas-x11 ecore-x11 edje eet embryo"
3 LICENSE = "MIT"
4 PR = "r4"
5
6 inherit e update-alternatives
7
8 SRC_URI = "${E_URI}/enlightenment-${PV}.tar.gz \
9            file://fix-configure.patch;patch=1 \
10            file://set-autoscroll-defaults.patch;patch=1 \
11            file://Xsession.d/98enlightenment"
12
13 S = "${WORKDIR}/enlightenment-${PV}"
14
15 PROFILE = "LOWRES_PDA"
16 PROFILE_c7x0 = "HIRES_PDA"
17 PROFILE_tosa = "HIRES_PDA"
18 PROFILE_spitz = "HIRES_PDA"
19 PROFILE_akita = "HIRES_PDA"
20
21 EXTRA_OECONF = "--with-profile=${PROFILE} \
22                 --with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
23                 --x-includes=${STAGING_INCDIR}/X11 \
24                 --x-libraries=${STAGING_LIBDIR}"
25
26 FILES_${PN} = "${bindir}/* ${libdir}/* ${datadir} ${sysconfdir}"
27
28 do_compile_prepend() {
29         find ${S} -name Makefile | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
30         find ${S} -name Makefile | xargs sed -i 's:/usr/X11R6/include:${STAGING_INCDIR}:'
31 }
32
33 do_install_append() {
34         install -d ${D}/${sysconfdir}/X11/Xsession.d
35         install -m 755 ${WORKDIR}/Xsession.d/98enlightenment ${D}/${sysconfdir}/X11/Xsession.d
36 }
37
38 ALTERNATIVE_PATH = "${bindir}/enlightenment"
39 ALTERNATIVE_NAME = "x-window-manager"
40 ALTERNATIVE_LINK = "${bindir}/x-window-manager"
41 ALTERNATIVE_PRIORITY = "16"