Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / dsplink / ti-codec-combos_3.16.bb
1 DESCRIPTION = "Codec combos for omap3530"
2 DEPENDS = "ti-codec-engine"
3 LICENCE = "unknown"
4
5 require ti-paths.inc
6
7 # TODO update this...
8 # https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_20_00_06/dmai_setuplinux_1_20_00_06.bin
9 # Install the above link and put the omap3530_dvsdk_combos_3_16.tar.gz file in the same directory as this recipe
10 SRC_URI = "file://omap3530_dvsdk_combos_3_16.tar.gz \
11    "
12
13 S = "${WORKDIR}/omap3530_dvsdk_combos_3_16"
14 # Yes, the xdc stuff still breaks with a '.' in PWD
15 PV = "316"
16 PR = "r10"
17
18 TARGET = "all"
19
20 export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/packages;${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-engine/cetools"
21
22 do_compile() {
23         sed -i -e s:/db/toolsrc/library/vendors2005/ti/c6x/6.0.16/Linux:${TITOOLSDIR}/${TICGTOOLSDIR}:g \
24         -e s:arm-none-linux-gnueabi-:${TARGET_PREFIX}:g \
25         -e s:/home/dvsdkval/workdir/OMAP3530/nfs/workdir/opt/toolchain/arm-2007q3:${CROSS_DIR}:g \
26         ${S}/config.bld
27
28         oe_runmake clean
29         oe_runmake
30 }
31
32 do_install () {
33         echo oe_runmake install
34
35         install -d ${D}/${datadir}/ti-codec-combos
36
37         cd ${S}
38
39         # grab the server executables
40         for i in $(find . -name "*.x64P") ; do
41                 install ${i} ${D}/${datadir}/ti-codec-combos
42         done
43         
44         # should copy the generated data sheets as well for reference
45 }
46
47 do_stage () {
48         install -d ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combos
49         cp -pPrf ${S}/* ${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/ti-codec-combos
50 }
51
52 FILES_ti-codec-combos = "${datadir}/ti-codec-combos/*"
53
54 INHIBIT_PACKAGE_STRIP = "1"
55
56 PACKAGE_ARCH = "${MACHINE_ARCH}"
57