gstreamer-ti: add more vars to make xdc a bit happier
[vuplus_openembedded] / packages / dsplink / gstreamer-ti_svn.bb
1 DEPENDS = "codec-engine dmai gstreamer gst-plugins-base gst-plugins-good gst-plugins-ugly libid3tag liboil libmad"
2
3 SRC_URI = "svn://omapzoom.org/svn/gstreamer_ti/trunk;module=gstreamer_ti;proto=https"
4 SRCREV = "87"
5
6 # Again, no '.' in PWD allowed :(
7 PV = "0+svnr${SRCREV}"
8
9 S = "${WORKDIR}/gstreamer_ti/ti_build/ticodecplugin"
10
11 inherit autotools
12
13 require ti-paths.inc
14
15 export DMAI_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/dmai"
16 export CE_INSTALL_DIR = "${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/cetools"
17 export CODEC_INSTALL_DIR = ""
18
19 export XDC_TARGET = "gnu.targets.arm.GCArmv5T"
20
21 XDC_PLATFORM = "foo"
22 # Assume every TI armv7a cpu is a 3530
23 XDC_PLATFORM_armv7a = "ti.platforms.evm3530"
24 export XDC_PLATFORM
25
26 # We need to add this to config.bld:
27 #GCArmv5T.cc.$unseal("opts");
28 #GCArmv5T.cc.opts = "SEDME_CCARCH";
29 #GCArmv5T.cc.$seal("opts");
30
31 do_compile_prepend() {
32         for i in $(find ${S} -name "config.bld") ; do
33                     sed -i -e s:SEDME_CCARCH:'${TARGET_CCARCH}': $i
34         done
35 }
36
37 CPPFLAGS_append = " -DPlatform_${PLATFORM}"
38
39 PACKAGE_ARCH = "${MACHINE_ARCH}"
40
41