Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / packages / dsplink / dmai_1.16.bb
1 DESCRIPTION = "Davinci (and OMAP) Multimedia Application Interface"
2 DEPENDS = "virtual/kernel codec-engine"
3 LICENCE = "unknown"
4
5 require ti-paths.inc
6
7 # https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_16_00_03/dmai_setuplinux_1_16_00_03.bin
8 # Install the above link and put the dmai_1_16_00_03.tar.gz file in the same directory as this recipe
9 SRC_URI = "file://dmai_1_16_00_03.tar.gz \
10           "
11
12 S = "${WORKDIR}/dmai_1_16_00_03"
13
14 PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16 TARGET = "all"
17 TARGET_neuros-osd2 = " dm6446_al dm6446_db"
18
19 export CE_INSTALL_DIR="${STAGING_DIR}/${MULTIMACH_TARGET_SYS}/codecengine/cetools"
20
21 do_compile() {
22         cd packages/ti/sdo/dmai
23         oe_runmake clean
24         oe_runmake ${TARGET}
25         cd packages/ti/sdo/dmai/apps
26         oe_runmake clean
27         oe_runmake ${TARGET}
28 }
29
30 do_install () {
31         oe_runmake install
32 }
33
34 do_stage () {
35         :
36 }
37