Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / dsniff / dsniff_2.3.bb
1 DESCRIPTION = "dsniff is a collection of tools for network auditing and penetration testing."
2 SECTION = "console/network"
3 HOMEPAGE = "http://www.monkey.org/~dugsong/dsniff/"
4 AUTHOR = "Dug Song <dugsong@monkey.org>"
5 LICENSE = "BSD"
6 PR = "r2"
7
8 # There is a significant API change beween 1.0.2a of libnet and
9 # 1.1.x, dsniff will only work with the older and there is no
10 # updated version of dnsniff.
11 DEPENDS = "virtual/db libpcap libnet-1.0 libnids openssl"
12
13 SRC_URI = "\
14   http://www.monkey.org/~dugsong/dsniff/dsniff-${PV}.tar.gz \
15   file://configure.patch;patch=1 \
16 "
17
18 inherit autotools
19
20 EXTRA_OECONF = "\
21   --without-x --with-db=${STAGING_LIBDIR}/.. \
22   --with-libpcap=${STAGING_LIBDIR}/.. \
23   --with-libnet=${STAGING_LIBDIR}/.. \
24   --with-libnids=${STAGING_LIBDIR}/.. \
25   --with-openssl=${STAGING_LIBDIR}/.. \
26 "
27 EXTRA_OEMAKE = "'install_prefix=${D}'"
28
29 CFLAGS =+ "-I${S}/missing"
30 LDFLAGS += "-lresolv"