Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / device-mapper / device-mapper_1.01.05.bb
1 SECTION = "libs"
2 DESCRIPTION = "The Device-mapper is a new component of the linux kernel \
3 that supports logical volume management. It is required by LVM2 and EVMS. \
4 The original LVM (included in stock 2.4 kernels) does not use it."
5 LICENSE = "GPL"
6 PR = "r3"
7
8 S = "${WORKDIR}/${PN}.${PV}"
9
10 SRC_URI = "ftp://sources.redhat.com/pub/dm/device-mapper.${PV}.tgz \
11            file://devmap-mknod-busybox.patch;patch=1 \
12            file://remove_insanity.patch;patch=1 "
13
14 inherit autotools update-rc.d
15
16 # The install-script will fail without this.
17 EXTRA_OECONF="--with-user= --with-group= "
18
19 INITSCRIPT_NAME = "devmap_mknod.sh"
20 INITSCRIPT_PARAMS = "defaults"
21
22 do_stage () {
23         install -m 0644 ${S}/lib/libdevmapper.h ${STAGING_INCDIR} || die "failed to install libdevmapper.h"
24         oe_libinstall -a -so -C lib/ioctl libdevmapper ${STAGING_LIBDIR}
25 }
26
27 do_install() {
28         autotools_do_install
29 #       oe_runmake install_static_lib
30         install -d ${D}/${libdir}/ioctl
31         install -m 755 ${S}/lib/ioctl/libdevmapper.a ${D}/${libdir}/ioctl/
32         install -D -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
33 }