Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / dbus / dbus-native_1.0.3.bb
1 require dbus.inc
2
3 PR = "r1"
4 DEFAULT_PREFERENCE = "-1"
5
6 inherit native
7
8 DEPENDS = "glib-2.0-native libxml2-native expat-native"
9 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
10
11 SRC_URI = "\
12   http://freedesktop.org/software/dbus/releases/dbus/dbus-${PV}.tar.gz \
13   file://cross.patch;patch=1 \
14   file://tmpdir.patch;patch=1 \
15   file://fedora-compile-fix.patch;patch=1 \
16   file://dbus-1.init \
17 "
18
19 do_stage() {
20         oe_runmake install
21         autotools_stage_all
22
23         # for dbus-glib-native introspection generation
24         install -d ${STAGING_DATADIR}/dbus
25         install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
26 }
27
28 do_install() {
29         :
30 }