enigma2: move to git
[vuplus_openembedded] / packages / dbus / dbus-native_1.0.3.bb
1 require dbus.inc
2
3 DEFAULT_PREFERENCE = "-1"
4
5 inherit native
6
7 DEPENDS = "glib-2.0-native libxml2-native expat-native"
8 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-${PV}"
9
10 SRC_URI = "\
11   http://freedesktop.org/software/dbus/releases/dbus/dbus-${PV}.tar.gz \
12   file://cross.patch;patch=1 \
13   file://tmpdir.patch;patch=1 \
14   file://dbus-1.init \
15 "
16
17 do_stage() {
18         oe_runmake install
19         autotools_stage_all
20
21         # for dbus-glib-native introspection generation
22         install -d ${STAGING_DATADIR}/dbus
23         install -m 0644 bus/session.conf ${STAGING_DATADIR}/dbus/session.conf
24 }
25
26 do_install() {
27         :
28 }