Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / cyrus-imapd / cyrus-imapd_2.2.12.bb
1 SECTION = "console/network"
2 DEPENDS = "cyrus-sasl virtual/db"
3 LICENSE = "BSD"
4 FILE_PR = "r12"
5 DEPENDS += "install-native"
6
7 SRC_URI = "ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-imapd-${PV}.tar.gz \
8            file://autotools.patch;patch=1 \
9            file://tail.patch;patch=1 \
10            file://imapopts.c.gcc4.patch;patch=1 \
11            file://imapopts.h.gcc4.patch;patch=1 \
12            file://cyrus \
13            file://cyrus.conf_2.2 \
14            file://imapd.conf_2.2 \
15            file://volatiles \
16            file://remove-install-strip.patch;patch=1 \
17            "
18
19 inherit autotools update-rc.d
20
21 INITSCRIPT_NAME = "cyrus"
22 INITSCRIPT_PARAMS = "start 56 3 4 5 . stop 15 0 1 6 ."
23
24 TARGET_LDFLAGS_append_thumb = " -lpthread"
25 EXTRA_OECONF = "--with-auth=unix \
26                 --with-dblib=berkeley \
27                 --with-bdb-libdir=${STAGING_LIBDIR} \
28                 --with-bdb-incdir=${STAGING_INCDIR} \
29                 --without-perl \
30                 --without-snmp"
31
32 FILES_${PN} += "${prefix}/cyrus/bin"
33
34 # All, lib/foo.c includes <config.h> from the top level directory and
35 # is natively compiled
36 BUILD_CPPFLAGS += " -I${S} -I${S}/et"
37
38 do_install_append () {
39         install -d ${D}${sysconfdir}/init.d
40         install -m 755 ${WORKDIR}/cyrus ${D}${sysconfdir}/init.d/cyrus
41         install -m 644 ${WORKDIR}/cyrus.conf_2.2 ${D}${sysconfdir}/cyrus.conf
42         install -m 644 ${WORKDIR}/imapd.conf_2.2 ${D}${sysconfdir}/imapd.conf
43         install -d ${D}${sysconfdir}/default/volatiles
44         install -m 644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/01_cyrus-imapd
45 }
46
47 pkg_postinst () {
48         /etc/init.d/populate-volatile.sh update
49 }
50
51 pkg_postrm () {
52 }
53