Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / ctrlproxy / ctrlproxy_2.6.2.bb
1 DESCRIPTION = "ctrlproxy is an IRC server with multiserver support."
2 SECTION = "console/network"
3 PRIORITY = "optional"
4 DEPENDS = "glib-2.0 libxml2 popt libpcre openssl"
5 PR = "r1"
6 LICENSE = "GPL"
7
8 SRC_URI = "http://sources.nslu2-linux.org/sources/ctrlproxy-2.6.2.tar.gz"
9 S = "${WORKDIR}/ctrlproxy-2.6.2/"
10
11 inherit autotools
12 # update-rc.d
13
14 #INITSCRIPT_NAME = "ctrlproxy"
15 #INITSCRIPT_PARAMS = "defaults 84"
16 # CONFFILES_${PN} = "${sysconfdir}/foo.conf"
17
18 # To fix this error in autotools_do_configure (which arises after a
19 # change to pkg-config pkg.m4):
20 #configure:314: error: possibly undefined macro: PKG_LIBS
21 do_configure() {
22         oe_runconf
23 }
24
25 CFLAGS += "-L${STAGING_LIBDIR}"
26
27 #do_install() {
28 #       autotools_do_install
29 #       install -d ${D}${sysconfdir}
30 #       install -d ${D}${sysconfdir}/init.d
31 #       install -m 0644 ${S}contrib/foo.conf ${D}${sysconfdir}
32 #       install -m 0755 ${WORKDIR}/foo.init ${D}${sysconfdir}/init.d/foo
33 #}
34