Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / chumby / chumby-firmware_1.2.bb
1 DESCRIPTION = "Binary Chumby firmware for kexec"
2 PACKAGES = "${PN}-k2 ${PN}-rfs2 ${PN}-bl ${PN}-psp ${PN}-k1 ${PN}-rfs1"
3 FILE_PR = "r1"
4
5 SRC_URI = "http://files.chumby.com/resources/chumby_fw_1_2.zip"
6 S = ${WORKDIR}
7
8 PACKAGE_ARCH = "chumby"
9 COMPATIBLE_MACHINES = "chumby"
10
11 do_install () {
12         cd ${S}/update1 && unzip k2.bin.zip
13         cd ${S}/update1 && unzip rfs2.bin.zip
14         cd ${S}/update2 && unzip bl.bin.zip
15         cd ${S}/update2 && unzip psp.bin.zip
16         cd ${S}/update2 && unzip k1.bin.zip
17         cd ${S}/update2 && unzip rfs1.bin.zip
18
19         install -d ${D}/boot/chumby-firmware/
20         install -m 0644 ${S}/update1/k2.bin ${D}/boot/chumby-firmware/
21         install -m 0644 ${S}/update1/rfs2.bin ${D}/boot/chumby-firmware/
22         install -m 0644 ${S}/update2/bl.bin ${D}/boot/chumby-firmware/
23         install -m 0644 ${S}/update2/psp.bin ${D}/boot/chumby-firmware/
24         install -m 0644 ${S}/update2/k1.bin ${D}/boot/chumby-firmware/
25         install -m 0644 ${S}/update2/rfs1.bin ${D}/boot/chumby-firmware/
26 }
27
28 FILES_${PN}-k2 = "/boot/chumby-firmware/k2.bin"
29 FILES_${PN}-rfs2 = "/boot/chumby-firmware/rfs2.bin"
30 FILES_${PN}-bl = "/boot/chumby-firmware/bl.bin"
31 FILES_${PN}-psp = "/boot/chumby-firmware/psp.bin"
32 FILES_${PN}-k1 = "/boot/chumby-firmware/k1.bin"
33 FILES_${PN}-rfs1 = "/boot/chumby-firmware/rfs1.bin"
34