merge of '49118a4c6035353c0f8cf1aa30297dd36e43241f'
[vuplus_openembedded] / packages / cacao / cacao_0.98+hg20071001.bb
1 require cacao.inc
2
3 PR = "r9"
4
5 SRC_URI = "\
6         http://jalimo.evolvis.org/repository/sources/cacao-${PV}.tar.bz2;md5sum=9ff10c929bd0cbf15909107c1aff7518 \
7         file://cacao-0.98+svn-classpath_var.patch;patch=1 \
8         file://cacao-0.98+hg-arm-cacheflush-fix.patch;patch=1 \
9         file://cacao-0.98+hg-attachthread.patch;patch=1 \
10         "
11
12 EXTRA_OECONF += "\
13     --enable-annotations \
14                 "
15
16 # Quirks for Nokia N800:
17 # - with mfloat-abi=softfp the runtime fails to run anything
18 # - without --enable-softfloat it cannot find files within Jars
19 TARGET_CC_ARCH_nokia800 = "-march=armv6j -mtune=arm1136jf-s -mfpu=vfp -mfloat-abi=soft"
20
21 EXTRA_OECONF_append_nokia800 = "--enable-softfloat"