iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / cacao / cacao_0.98+hg20071001.bb
1 require cacao.inc
2
3 PR = "r8"
4
5 SRC_URI = "\
6         http://jalimo.evolvis.org/repository/sources/cacao-${PV}.tar.bz2;md5sum=9ff10c929bd0cbf15909107c1aff7518 \
7         file://cacao-0.98+svn-libdir.diff;patch=1 \
8         file://cacao-0.98+svn-classpath_var.patch;patch=1 \
9         file://cacao-0.98+hg-arm-cacheflush-fix.patch;patch=1 \
10         file://cacao-0.98+hg-attachthread.patch;patch=1 \
11         "
12
13 EXTRA_OECONF += "\
14     --enable-annotations \
15                 "
16
17 # Quirks for Nokia N800:
18 # - with mfloat-abi=softfp the runtime fails to run anything
19 # - without --enable-softfloat it cannot find files within Jars
20 TARGET_CC_ARCH_nokia800 = "-march=armv6j -mtune=arm1136jf-s -mfpu=vfp -mfloat-abi=soft"
21
22 EXTRA_OECONF_append_nokia800 = "--enable-softfloat"