Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / c3110x / cx3110x_1.1.bb
1 DESCRIPTION = "cx3110x wifi support as found in the Nokia 770/800"\r
2 SECTION = "kernel/modules"\r
3 LICENSE = "GPL"\r
4 FILE_PR = "r4"\r
5 \r
6 COMPATIBLE_MACHINE = "(nokia770|nokia800)"\r
7 \r
8 export KERNEL_SRC_DIR = ${STAGING_KERNEL_DIR}\r
9 export LDFLAGS = ""\r
10 \r
11 SRC_URI = "https://garage.maemo.org/frs/download.php/939/cx3110x-1.1.tar.gz \\r
12            file://umac_binary.patch;patch=1 \\r
13            http://use.the.umac.ko.from.your.own.nokia800/umac.ko"\r
14 \r
15 S = "${WORKDIR}/cx3110x-${PV}"\r
16 \r
17 inherit module\r
18 \r
19 do_compile() {\r
20         cp ${WORKDIR}/umac.ko ${S}/src/binary_umac.o\r
21         ${OBJCOPY} ${S}/src/binary_umac.o -R __ksymtab\r
22         ${OBJCOPY} ${S}/src/binary_umac.o -R __ksymtab_strings\r
23         ${OBJCOPY} ${S}/src/binary_umac.o -R .gnu.linkonce.this_module\r
24         ${OBJCOPY} ${S}/src/binary_umac.o -R .modinfo\r
25         ${OBJCOPY} ${S}/src/binary_umac.o -R .init.text\r
26         ${OBJCOPY} ${S}/src/binary_umac.o -R .exit.text\r
27 \r
28         oe_runmake modules \r
29 }\r
30 \r