Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / busybox / slingbox_1.3.1.bb
1 DESCRIPTION = "SlingBox is a minimal version of BusyBox with just enough functionality \
2 to enable ipkg to run on an Unslung NSLU2 device."
3 HOMEPAGE = "http://www.busybox.net"
4 LICENSE = "GPL"
5 SECTION = "base"
6 PRIORITY = "required"
7 PR = "r3"
8 COMPATIBLE_MACHINE = "nslu2"
9
10 SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
11            file://defconfig \
12            file://shadow_h_is_required.patch;patch=1 \
13            file://df_rootfs.patch;patch=1 \
14            file://lazy_umount.patch;patch=1 \
15            file://halt.patch;patch=1 \
16            file://fdisk-readhex.patch;patch=1 \
17            file://trylink-bash.patch;patch=1 \
18            file://slingbox_name.patch;patch=1 \
19            file://slingbox.patch;patch=1"
20
21 S = "${WORKDIR}/busybox-${PV}"
22
23 export EXTRA_CFLAGS = "${CFLAGS}"
24 EXTRA_OEMAKE_append = " V=1 ARCH=arm CROSS_COMPILE=${TARGET_PREFIX}"
25
26 FILES_${PN} = "/"
27 FILES_${PN}-doc = ""
28 FILES_${PN}-dev = ""
29 FILES_${PN}-locale = ""
30
31 inherit cml1
32
33 do_configure () {
34         install -m 0644 ${WORKDIR}/defconfig ${S}/.config
35         cml1_do_configure
36 }
37
38 do_compile () {
39         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
40         base_do_compile
41 }
42
43 do_install () {
44         unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
45         oe_runmake "PREFIX=${D}" install
46
47         # Just in case fdisk is compiled in, do not overwrite the Linksys one
48         rm -f ${S}/_install/sbin/fdisk
49
50         cp -pPR ${S}/_install/* ${D}/
51 }