merge of 425cf1b391611c169a1c3b78f1fe86df088902b9
[vuplus_openembedded] / packages / boa / boa_0.94.13.bb
1 DESCRIPTION = "Lightweight and High Performance WebServer"
2 SECTION = "console/network"
3 LICENSE = "GPL"
4 RDEPENDS = "mime-support"
5 RPROVIDES = "httpd"
6 PR = "r3"
7
8 SRC_URI = "http://www.boa.org/boa-${PV}.tar.gz \
9            file://cgi.patch;patch=1;pnum=2 \
10            file://debian-patch.diff;patch=1;pnum=2 \
11            file://boa.conf \
12            file://boa.init"
13
14 S = "${WORKDIR}/boa-${PV}/src"
15
16 inherit autotools update-rc.d
17
18 INITSCRIPT_NAME = "boa"
19 INITSCRIPT_PARAMS = "defaults 20"
20
21 CFLAGS_append = " -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"
22 #CFLAGS_append = " -DSERVER_ROOT=..."
23
24 do_install() {
25         install -d ${D}${sbindir}
26         install -d ${D}${libdir}/${PN}
27         install -m 0755 boa                     ${D}${sbindir}
28         install -m 0755 boa_indexer             ${D}${libdir}/${PN}
29
30         install -d ${D}${sysconfdir}/${PN}
31         install -d ${D}${sysconfdir}/init.d
32         install -m 0640 ${WORKDIR}/boa.conf     ${D}${sysconfdir}/${PN}
33         install -m 0755 ${WORKDIR}/boa.init     ${D}${sysconfdir}/init.d/boa
34
35         install -d ${D}${mandir}/man8
36         install -m 0644 ${S}/../docs/boa.8 ${D}${mandir}/man8
37 }