Merge branch 'org.openembedded.dev' of git@git.openembedded.net:/openembedded into...
[vuplus_openembedded] / packages / bluez / bluez-utils_3.36.bb
1 require bluez-utils3.inc
2
3 PR = "r1"
4
5 # removed hciattach-ti-bts.patch (landed upstream)
6 SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
7            file://hcid.conf \
8            file://sbc-thumb.patch;patch=1"
9
10 # see bluez-utils3.inc for the explanation of these option
11 EXTRA_OECONF = " \
12                  --enable-bccmd \
13                  --enable-hid2hci \
14                  --enable-hidd \
15                  --enable-pand \
16                  --enable-dund \
17                  --disable-alsa \ 
18                  --disable-cups \
19                  --enable-glib \
20                  --disable-sdpd \
21                  --enable-network \
22                  --enable-serial \
23                  --enable-input \
24                  --enable-audio \
25                  --enable-echo \
26                  --enable-configfile \
27                  --enable-initscripts \
28                  --enable-test \
29                 " 
30
31 CONFFILES_${PN} = " \
32                    ${sysconfdir}/bluetooth/hcid.conf \
33                    ${sysconfdir}/default/bluetooth \
34                   "
35
36 CONFFILES_${PN}-compat = " \
37                           ${sysconfdir}/bluetooth/rfcomm.conf \
38                          "
39
40 PACKAGES =+ "bluez-audio"
41
42 FILES_${PN} = " \
43                ${base_sbindir}/hcid \
44                ${libdir}/bluetooth/plugins/*.so \
45                ${sysconfdir}/init.d/bluetooth \
46                ${sysconfdir}/bluetooth/hcid.conf \
47                ${sysconfdir}/default \
48                ${sysconfdir}/dbus-1 \
49                ${base_sbindir}/hciattach \
50               "
51
52 FILES_bluez-audio = " \
53                      ${libdir}/bluetooth/plugins/libaudio.so \
54                      ${libdir}/gstreamer-0.10/*.so \
55                     "
56
57 FILES_${PN}-dbg += " \
58                     ${libdir}/bluetooth/plugins/.debug \
59                     ${libdir}/gstreamer-0.10/.debug \
60                    "
61
62 FILES_${PN}-dev += " \
63                     ${libdir}/bluetooth/plugins/*.la \
64                     ${libdir}/gstreamer-0.10/*.la \
65                    "