merge of '49118a4c6035353c0f8cf1aa30297dd36e43241f'
[vuplus_openembedded] / packages / bluez / bluez-utils_3.33.bb
1 require bluez-utils3.inc
2
3 # see bluez-utils3.inc for the explanation of these option
4 EXTRA_OECONF = " \
5                  --enable-bccmd \
6                  --enable-hid2hci \
7                  --disable-alsa \ 
8                  --disable-cups \
9                  --enable-glib \
10                  --disable-sdpd \
11                  --enable-network \
12                  --enable-serial \
13                  --enable-input \
14                  --enable-audio \
15                  --enable-echo \
16                  --enable-configfile \
17                  --enable-initscripts \
18                  --enable-test \
19                 " 
20
21 CONFFILES_${PN} = " \
22                    ${sysconfdir}/bluetooth/hcid.conf \
23                    ${sysconfdir}/default/bluetooth \
24                   "
25
26 CONFFILES_${PN}-compat = " \
27                           ${sysconfdir}/bluetooth/rfcomm.conf \
28                          "
29
30 PACKAGES =+ "bluez-audio"
31
32 FILES_${PN} = " \
33                ${base_sbindir}/hcid \
34                ${libdir}/bluetooth/plugins/*.so \
35                ${sysconfdir}/init.d/bluetooth \
36                ${sysconfdir}/bluetooth/hcid.conf \
37                ${sysconfdir}/default \
38                ${sysconfdir}/dbus-1 \
39                ${base_sbindir}/hciattach \
40               "
41
42 FILES_bluez-audio = " \
43                      ${libdir}/bluetooth/plugins/libaudio.so \
44                      ${libdir}/gstreamer-0.10/*.so \
45                     "
46
47 FILES_${PN}-dbg += " \
48                     ${libdir}/bluetooth/plugins/.debug \
49                     ${libdir}/gstreamer-0.10/.debug \
50                    "
51
52 FILES_${PN}-dev += " \
53                     ${libdir}/bluetooth/plugins/*.la \
54                     ${libdir}/gstreamer-0.10/*.la \
55                    "