Merge branch 'org.openembedded.dev' of git://git.openembedded.net/openembedded into...
[vuplus_openembedded] / packages / balsa / balsa_2.0.17.bb
1 DESCRIPTION = "Balsa is an e-mail client for GNOME, highly configurable and \
2 incorporating all the features you would expect in a robust mail client."
3 HOMEPAGE = "http://balsa.gnome.org"
4 SECTION = "x11/network"
5 LICENSE = "GPL"
6 DEPENDS = "libesmtp glib-2.0 libgnome libgnomeui gtk+ gnome-vfs libbonobo aspell libpcre libtool openssl gtkhtml-3.0"
7 RDEPENDS = "gdk-pixbuf-loader-xpm"
8 FILE_PR = "r3"
9
10 SRC_URI = "http://talinux.fi.tal.org/pub/talinux/sources/balsa-${PV}.tar.bz2 \
11            file://libmutt-cross.patch;patch=1 \
12            file://desktop-file-fix.patch;patch=1"
13
14 inherit autotools
15
16 EXTRA_OECONF = "--with-ssl"
17
18 do_configure_prepend() {
19         # aclocal seems to insist on looking in here.  Make sure it exists.
20         mkdir -p ${S}/m4
21         # work around automake lossage with AC_CONFIG_AUX_DIR
22         ( cd libmutt; libtoolize --force ; cp ../ltmain.sh . )
23 }
24