merge of '45fb4fa94d52a65c3a3fa636c6122139173dfa8d'
[vuplus_openembedded] / packages / autofs / autofs_4.1.4.bb
1 DESCRIPTION = "Kernel based automounter for linux."
2 SECTION = "base"
3 LICENSE = "GPL"
4
5 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
6            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
7            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
8            ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
9            file://cross.patch;patch=1 \
10            file://Makefile.rules-cross.patch;patch=1 \
11            file://install.patch;patch=1"
12
13 inherit autotools
14
15 EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
16 PARALLEL_MAKE = ""
17
18 do_configure_prepend () {
19         if [ ! -e acinclude.m4 ]; then
20                 cp aclocal.m4 acinclude.m4
21         fi
22 }
23
24 do_install () {
25         oe_runmake 'INSTALLROOT=${D}' install
26 }