merge
[vuplus_openembedded] / packages / apr / apr-util_1.2.7.bb
1 DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2 SECTION = "libs"
3 DEPENDS = "apr expat gdbm"
4 LICENSE = "Apache License, Version 2.0"
5
6 PR = "r2"
7
8 # apache mirrors?
9 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz"
10
11 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
12                 --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
13                 --without-sqlite2 \
14                 --without-sqlite3 \
15                 --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
16
17
18 inherit autotools lib_package binconfig
19
20 OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
21
22 do_configure() {
23   cp ${STAGING_DATADIR}/apr_rules.mk ${S}/build/rules.mk
24   oe_runconf
25 }
26
27 do_stage() {
28   autotools_stage_all
29   sed -i s,/usr/lib/libgdbm.la,-lgdbm,g   ${STAGING_LIBDIR}/libaprutil-1.la
30   sed -i s,/usr/lib/libexpat.la,-lexpat,g ${STAGING_LIBDIR}/libaprutil-1.la
31   sed -i s,/usr/lib/libapr-1.la,-lapr-1,g ${STAGING_LIBDIR}/libaprutil-1.la
32 }