merge of '178eac00dc5aa8338d42e8e203633bec7817bbf6'
[vuplus_openembedded] / packages / apr / apr-util_1.2.7.bb
1 DESCRIPTION = "Apache Portable Runtime (APR) companion library"
2 SECTION = "libs"
3 DEPENDS = "apr expat gdbm"
4 LICENSE = "Apache License, Version 2.0"
5
6 PR = "r3"
7
8 # apache mirrors?
9 SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.gz \
10            file://configure_fixes.patch;patch=1"
11
12 EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
13                 --with-gdbm=${STAGING_DIR_HOST}${layout_prefix} \
14                 --without-sqlite2 \
15                 --without-sqlite3 \
16                 --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
17
18
19 inherit autotools lib_package binconfig
20
21 OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
22
23 do_configure_prepend () {
24         cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
25 }
26
27 do_stage() {
28         autotools_stage_all
29 }