iscsi-target: Add package iscsi-target
[vuplus_openembedded] / packages / angstrom / angstrom-led-config.bb
1 DESCRIPTION = "Configuration files for runtime LED configuration" 
2
3 #PV = "${DISTRO_VERSION}"
4 PR = "r0"
5 PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7 inherit update-rc.d
8 INITSCRIPT_NAME = "led-config"
9
10 SRC_URI = "file://led-config \
11            file://leds \
12           "     
13
14 do_compile() {
15         :
16 }
17
18
19 do_install () {
20         install -d ${D}/${sysconfdir}/default
21         install -d ${D}/${INIT_D_DIR}
22
23         install -m 0644 ${WORKDIR}/leds ${D}/${sysconfdir}/default/
24         install -m 0755 ${WORKDIR}/led-config ${D}/${INIT_D_DIR}
25 }
26
27 CONFFILES_${PN} += "${sysconfdir}/default/leds \
28                     ${INIT_D_DIR}/led-config \
29                    "
30